Sellfy - Errors when accessing Sellfy – Incident details

All systems operational

Errors when accessing Sellfy

Resolved
Major outage
Started 5 months agoLasted 2 minutes

Affected

Sellfy Website

Operational from 12:47 AM to 12:47 AM, Major outage from 12:47 AM to 12:49 AM

User dashboard

Operational from 12:47 AM to 12:47 AM, Major outage from 12:47 AM to 12:49 AM

Email delivery

Operational from 12:47 AM to 12:47 AM, Major outage from 12:47 AM to 12:49 AM

Hosted storefronts

Operational from 12:47 AM to 12:47 AM, Major outage from 12:47 AM to 12:49 AM

Mobile app

Operational from 12:47 AM to 12:47 AM, Major outage from 12:47 AM to 12:49 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    You may experience an issue accessing your Sellfy account or Sellfy-hosted storefront. Our team will work to resolve this as soon as possible.