Sellfy - Expired SSL certificate for Sellfy .store subdomains – Incident details
Report an issue
Report an issue
Dark mode
All systems operational
Expired SSL certificate for Sellfy .store subdomains
Resolved
Major outage
Started 28 days ago
Lasted 30 minutes
Affected
Hosted storefronts
Major outage from 1:43 PM to 2:14 PM
Updates
Resolved
April 21, 2026 at 2:14 PM
Resolved
April 21, 2026 at 2:14 PM
This incident has been resolved.
Identified
April 21, 2026 at 1:43 PM
Identified
April 21, 2026 at 1:43 PM
We are continuing to work on a fix for this incident.