Sellfy - Homepage not accessible – Incident details

All systems operational

Homepage not accessible

Resolved
Major outage
Started 5 months agoLasted 18 minutes

Affected

Sellfy Website

Operational from 4:03 PM to 4:03 PM, Major outage from 4:03 PM to 4:21 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    Our homepage is currently not accessible due to underlying technical issue. Our engineers are working hard to resolve this ASAP.