Sellfy subscription difficulties
Incident Report for Sellfy
Resolved
This has been resolved.
Posted Apr 19, 2024 - 20:26 UTC
Identified
We are experiencing issues with the service powering Sellfy account subscriptions. Some actions related to your Sellfy subscription such as making payments or modifying your subscription may not be available. Please try again later.
Posted Apr 19, 2024 - 19:22 UTC
This incident affected: Sellfy Website.